Mikrotik merupakan sebuah perusahaan di Latvia yang memproduksi Routerboard dan RouterOS. Saat ini Mikrotik juga dapat dijadikan Router secara Cloud berfungsi banyak hal mulai dari VPN Server, IP Forwarding, dan masih banyak yang lain.

 

Cloudmatika akan memberikan panduan untuk memasang Cloud Hosted Router (CHR) Mikrotik di Ubuntu Server.

 

Namun sebelumnya pastikan anda sudah melakukan Add New Server Linux OS Ubuntu VM

 

  • Setelah server dapat berhasil membuat Cloud Server dan masuk ke Server melalui SSH. Jalankan perintah berikut :

 

wget https://download2.mikrotik.com/routeros/6.38.3/chr-6.38.3.img.zip -O chr.img.zip && \

gunzip -c chr.img.zip > chr.img && \

mount -o loop,offset=33554944 chr.img /mnt && \

ADDRESS=ip addr show ensp0 | grep global | cut -d' ' -f 6 | head -n 1 && \

GATEWAY=ip route list | grep default | cut -d' ' -f 3 && \

echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]

/ip route add gateway=$GATEWAY

/ip dns set servers=1.1.1.1,1.0.0.1

" > /mnt/rw/autorun.scr && \

umount /mnt && \

echo u > /proc/sysrq-trigger && \

dd if=chr.img bs=1024 of=/dev/vda

 

  • Jika berhasil maka akan menampilkan seperti ini :

  • Jika sudah menjalankan perintah sebelumnya, silahkan anda untuk melakukan reboot dengan perintah :

sudo reboot

  • Jangan lupa untuk melakukan konfigurasi firewall di Control Panel dengan membuka port 8291 untuk winbox
  • Buka firewall lalu klik Add New Rule 

  • Jika sudah silahkan masukkan port 8291 

  • Jika berhasil maka akan menampilkan seperti ini :