Mikrotik merupakan sebuah perusahaan di Latvia yang memproduksi Routerboard dan RouterOS. Saat ini Mikrotik juga dapat dijadikan Router secara Cloud berfungsi banyak hal mulai dari VPN Server, IP Forwarding,  dan masih banyak yang lain.

 

Cloudmatika akan memberikan panduan untuk memasang Cloud Hosted Router (CHR) Mikrotik di CentOS.

 

Namun, sebelumnya pastikan sudah melakukan Add New Server Linux OS CentOS VM

 

Setelah server dapat berhasil membuat Cloud Server dan masuk ke Server melalui SSH. Jalankan perintah berikut :

  • Lalu, buka Putty untuk mengakses server Anda

  • Silakan masukkan IP server Anda 

  • Login menggunakan username dan password Anda
  • Silakan Anda install wget dengan mengetikkan perintah :


yum install wget -y

 

  • Lalu ketik perintah berikut untuk mendownload mikrotik CHR : 
    $ yum update -y
    
    $ yum install wget unzip -y
    
    $ wget https://download.mikrotik.com/routeros/6.47.6/chr-6.47.6.img.zip -O mik-chr.img.zip
  • lalu unzip file yang telah di download
    $ unzip mik-chr.img.zip
  • setelahnya pastikan hasil unzip dengan perintah ls
    $ ls

    result : 
    chr-6.47.6.img  mik-chr.img.zip

  • Setelahnya lakukan mounting terhadap file image mikrotik : 
    $ mount -o loop,offset=512 chr-6.47.6.img /mnt


    untuk memastikan file telah termounting, bisa menggunakan perintah berikut : 

    $ ls /mnt

    result : 
    bin  boot  dev  lost+found  nova  rw  SHOW_LICENSE  UPGRADED  var

  • Untuk melakukan route, anda dapat menggunakan command berikut : 
    ADDRESS=`ip addr show eth1 | grep global | cut -d' ' -f 6 | head -n 1` && \
    
    GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
    
    echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
    
    /ip route add gateway=$GATEWAY
    
    /ip dns set servers=8.8.8.8,8.8.4.4" > /mnt/rw/autorun.scr


    untuk memastikan perintah sudah tercatat, anda dapat memastikan dengan perintah berikut : 

    $ cat /mnt/rw/autorun.scr

    result :
    /ip address add address=103.xxx interface=[/interface ethernet find where name=ether1] 


    /ip route add gateway=103.xxx


    /ip dns set servers=8.8.8.8,8.8.4.4

  • untuk unmount image mikrotik anda dapat menggunakan perintah berikut : 
    $ echo u > /proc/sysrq-trigger



  • untuk memindahkan record anda dapat menggunakan perintah : 
    $ dd if=chr-6.47.6.img bs=1024 of=/dev/vda

    result : 

    5536+0 records in 


    65536+0 records out

  • Selanjutnya, silakan Anda lakukan reboot dengan menggunakan perintah :

sudo reboot

  • Lalu, silakan Anda lakukan konfigurasi firewall pada control panel dengan membuka port 8291 untuk winbox

  • Silakan Anda cek menggunakan Web Console, jika berhasil maka akan menampilkan seperti ini :